Интерактивный календарь в Excel

Рубрика: 7. Полезняшки Excel

Если вам нужен интерактивный календарь в Excel, эта заметка для вас. [1]

%d1%80%d0%b8%d1%81-1-%d0%ba%d0%b0%d0%bb%d0%b5%d0%bd%d0%b4%d0%b0%d1%80%d1%8c-%d0%bd%d0%b0-%d0%b1%d0%b0%d0%b7%d0%b5-%d1%81%d0%bb%d0%be%d0%b6%d0%bd%d0%be%d0%b9-%d1%84%d0%be%d1%80%d0%bc%d1%83%d0%bb

Рис. 1. Календарь на базе сложной формулы массива

Скачать заметку в формате Word или pdf, примеры в формате Excel

Чтобы создать такой календарь, выполните следующие действия:

  1. Выделите диапазон В2:Н2, объедините ячейки с помощью команды Главная –> Выравнивание –> Объединить и поместить в центре.
  2. Введите дату в объединенный диапазон.
  3. День месяца неважен, поэтому измените формат ячейки на специальный, в котором не отображается день. Например, я применил: ММММ ГГГГ.
  4. Введите сокращенные названия дней в диапазон ВЗ:НЗ.
  5. Выделите диапазон В4:Н9, и введите формулу массива без разрывов строк. Для ввода формулы массива нажмите Ctrl+Shift+Enter (подробнее о формулах массива см. Майкл Гирвин. Ctrl+Shift+Enter. Освоение формул массива в Excel).

=ЕСЛИ(МЕСЯЦ(ДАТА(ГОД(B2);МЕСЯЦ(B2);1))<>МЕСЯЦ(ДАТА(ГОД(B2);МЕСЯЦ(B2 );1)-(ДЕНЬНЕД(ДАТА(ГОД(B2);МЕСЯЦ(B2);1);2)-1)+{0:1:2:3:4:5:6}*7+{1;2;3;4;5;6;7}-1);"";ДАТА(ГОД(B2);МЕСЯЦ(B2);1)-(ДЕНЬНЕД(ДАТА(ГОД(B2);МЕСЯЦ(B2);1);2)-1)+{0:1:2:3:4:5:6}*7+{1;2;3;4;5;6;7}-1)

  1. Выделите диапазон В4:Н9 и выполните команду Главная –> Число –> Другие числовые форматы, чтобы отобразить вкладку Число диалогового окна Формат ячеек.
  2. В окне Формат ячеек выберите вариант Все форматы и введите в поле Тип следующий пользовательский числовой формат, отображающий только день: Д.
  3. Откорректируйте ширину столбцов и отформатируйте ячейки так, как хотите. Измените дату и год в ячейке В2, и календарь автоматически обновится.

Создав такой календарь, вы сможете скопировать диапазон в любую другую книгу или на любой другой лист. Попробуйте в качестве небольшого домашнего задания создать календарь, отображающий текущий, предыдущий и последующий месяцы (решение во вложенном Excel-файле).

[1] По материалам книги Джон Уокенбах. Excel 2013. Трюки и советы. – СПб.: Питер, 2014. – С. 131, 132.

Комментарии: 2 комментария

Добрый день!
Можете создать отдельный док-файл, где будут все фишки ексель?
плиз

Андрей, для этого у меня есть опция «Полезняшки Excel» в главном меню сайта. Правда, я его давно не обновлял. Займусь в ближайшее время))


Прокомментировать