Excel. Работа с номерами кредитных карт

Рубрика: 7. Полезняшки Excel

Если вы когда-либо пытались вводить в ячейку шестнадцатизначный номер кредитной карты, то, вероятно, замечали, что Excel всегда заменяет последнюю цифру на 0. [1] Почему программа так поступает? Дело в том, что Excel обеспечивает обработку чисел с точностью только до 15 знаков (поэкспериментируйте).

%d1%80%d0%b8%d1%81-1-%d0%b2%d0%b2%d0%be%d0%b4-%d0%bd%d0%be%d0%bc%d0%b5%d1%80%d0%be%d0%b2-%d0%ba%d1%80%d0%b5%d0%b4%d0%b8%d1%82%d0%bd%d1%8b%d1%85-%d0%ba%d0%b0%d1%80%d1%82-%d1%81-%d0%b4%d0%b5%d1%84

Рис. 1. Ввод номеров кредитных карт с дефисами

Скачать заметку в формате Word или pdf, примеры в формате Excel

Сохранить на рабочем листе номер кредитной карты можно тремя способами:

  • поставить перед номером кредитной карты апостроф — '. Excel будет интерпретировать данные в ячейке, как текст, а не как число (при этом сам апостроф не выводится; я использую этот прием, чтобы отображать в ячейке формулы; введите в ячейку, например, '=СУММ(A1:A2). – Прим. Багузина);
  • предварительно отформатировать ячейку или диапазон с помощью числового формата текстовый — выделите диапазон, выполните команду Главная –> Число, а потом выберите пункт Текстовый из раскрывающегося списка Числовой формат;
  • ввести номер карточки, вставив в него дефисы или пробелы — при наличии дефиса (или любого другого нечислового символа) Excel интерпретирует такую запись как текст (рис. 1).

Разумеется, этот совет применим и при работе с другими большими числами (например, номерами деталей), которые не используются при расчетах.

Если вы переносите номера кредитных карточек из текстового файла в формате CSV, то Excel импортирует эти номера как значения и ошибочно меняет последнюю цифру на 0. Чтобы избежать этого, не выполняйте импорт с помощью команды Файл –> Открыть. Вместо этого воспользуйтесь командой Данные –> Получить внешние данные –> Из текста. При работе с этой командой Excel отображает мастер импорта текстов. В шаге 3 работы с этим мастером укажите текстовый в качестве формата данных для столбцов с номерами кредитных карточек. Потренируйтесь на следующей файле в формате CSV.

%d1%80%d0%b8%d1%81-2-%d0%b8%d0%bc%d0%bf%d0%be%d1%80%d1%82-%d1%84%d0%b0%d0%b9%d0%bb%d0%b0-%d1%81%d0%be%d0%b4%d0%b5%d1%80%d0%b6%d0%b0%d1%89%d0%b5%d0%b3%d0%be-%d0%bd%d0%be%d0%bc%d0%b5%d1%80%d0%b0

Рис. 2. Импорт файла, содержащего номера кредитных карт

[1] По материалам книги Джон Уокенбах. Excel 2013. Трюки и советы. – СПб.: Питер, 2014. – С. 182.


Прокомментировать